What’s Vulnerable › Vulnerabilities
CVE-2019-25009
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-31 · updated 2026-06-17
- Weakness: CWE-415
Description
An issue was discovered in the http crate before 0.1.20 for Rust. The HeaderMap::Drain API can use a raw pointer, defeating soundness.
Affected products
- Hyper Http: before 0.1.20 — fixed in 0.1.20
How to fix
Upgrade to a fixed version: Hyper Http 0.1.20. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2019-0034.html
- https://rustsec.org/advisories/RUSTSEC-2019-0034.html
Get alerted when CVE-2019-25009 or the next vulnerability affects your stack