What’s Vulnerable › Vulnerabilities
CVE-2019-25024
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-19 · updated 2026-06-17
- Weakness: CWE-78
Description
OpenRepeater (ORP) before 2.2 allows unauthenticated command injection via shell metacharacters in the functions/ajax_system.php post_service parameter.
Affected products
- Alleghenycreative Openrepeater: before 2.2 — fixed in 2.2
How to fix
Upgrade to a fixed version: Alleghenycreative Openrepeater 2.2. Check the vendor advisory for mitigations.
References
- https://github.com/MarkLee131/awesome-web-pocs/blob/main/CVE-2019-25024.md
- https://github.com/OpenRepeater/openrepeater/issues/66
- https://github.com/codexlynx/CVE-2019-25024
- https://github.com/OpenRepeater/openrepeater/issues/66
- https://github.com/codexlynx/CVE-2019-25024
Get alerted when CVE-2019-25024 or the next vulnerability affects your stack