What’s Vulnerable › Vulnerabilities

CVE-2019-25028: Stored cross-site scripting in Grid component in Vaadin 7 and 8

Description

Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector

Affected products

How to fix

Upgrade to a fixed version: Vaadin 7.7.20, 8.8.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-25028 or the next vulnerability affects your stack