What’s Vulnerable › Vulnerabilities
CVE-2019-25041
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-27 · updated 2026-06-17
- Weakness: CWE-617
Description
Unbound before 1.9.5 allows an assertion failure via a compressed name in dname_pkt_copy. NOTE: The vendor disputes that this is a vulnerability. Although the code may be vulnerable, a running Unbound installation cannot be remotely or locally exploited
Affected products
- Debian Linux: 9.0
- NLnet Labs Unbound: before 1.9.5 — fixed in 1.9.5
How to fix
Upgrade to a fixed version: NLnet Labs Unbound 1.9.5. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2021/05/msg00007.html
- https://ostif.org/our-audit-of-unbound-dns-by-x41-d-sec-full-results/
- https://security.netapp.com/advisory/ntap-20210507-0007/
- https://lists.debian.org/debian-lts-announce/2021/05/msg00007.html
- https://ostif.org/our-audit-of-unbound-dns-by-x41-d-sec-full-results/
- https://security.netapp.com/advisory/ntap-20210507-0007/
Get alerted when CVE-2019-25041 or the next vulnerability affects your stack