What’s Vulnerable › Vulnerabilities
CVE-2019-25043
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-755
Description
ModSecurity 3.x before 3.0.4 mishandles key-value pair parsing, as demonstrated by a "string index out of range" error and worker-process crash for a "Cookie: =abc" header.
Affected products
- owasp-modsecurity ModSecurity: from 3.0.0 before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: owasp-modsecurity ModSecurity 3.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/SpiderLabs/ModSecurity/issues/2566
- https://github.com/SpiderLabs/ModSecurity/issues/2566
Get alerted when CVE-2019-25043 or the next vulnerability affects your stack