What’s Vulnerable › Vulnerabilities
CVE-2019-25052
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-327
Description
In Linaro OP-TEE before 3.7.0, by using inconsistent or malformed data, it is possible to call update and final cryptographic functions directly, causing a crash that could leak sensitive information.
Affected products
- Linaro/OP-TEE OP-TEE: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: Linaro/OP-TEE OP-TEE 3.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/OP-TEE/optee_os/commit/34a08bec755670ea0490cb53bbc68058cafc69b6
- https://github.com/OP-TEE/optee_os/security/advisories/GHSA-pgwr-qmgh-vhmf
- https://github.com/OP-TEE/optee_os/commit/34a08bec755670ea0490cb53bbc68058cafc69b6
- https://github.com/OP-TEE/optee_os/security/advisories/GHSA-pgwr-qmgh-vhmf
Get alerted when CVE-2019-25052 or the next vulnerability affects your stack