What’s Vulnerable › Vulnerabilities
CVE-2019-25055
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-27 · updated 2026-06-17
Description
An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.
Affected products
- Libpulse-Binding Project Libpulse-Binding: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Libpulse-Binding Project Libpulse-Binding 2.6.0. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/libpulse-binding/RUSTSEC-2019-0038.md
- https://rustsec.org/advisories/RUSTSEC-2019-0038.html
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/libpulse-binding/RUSTSEC-2019-0038.md
- https://rustsec.org/advisories/RUSTSEC-2019-0038.html
Get alerted when CVE-2019-25055 or the next vulnerability affects your stack