What’s Vulnerable › Vulnerabilities
CVE-2019-25060: WP-GraphQL < 0.3.5 - Improper Access Control
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-09 · updated 2026-06-17
- Weakness: CWE-284
Description
The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.
Affected products
- WPGraphQL: before 0.3.5 — fixed in 0.3.5
How to fix
Upgrade to a fixed version: WPGraphQL 0.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/wp-graphql/wp-graphql/pull/900
- https://wpscan.com/vulnerability/393be73a-f8dc-462f-8670-f20ab89421fc
- https://github.com/wp-graphql/wp-graphql/pull/900
- https://wpscan.com/vulnerability/393be73a-f8dc-462f-8670-f20ab89421fc
Get alerted when CVE-2019-25060 or the next vulnerability affects your stack