What’s Vulnerable › Vulnerabilities
CVE-2019-25078: pacparser pacparser.c pacparser_find_proxy buffer overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-13 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.
Affected products
- pacparser: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: pacparser 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/manugarg/pacparser/commit/853e8f45607cb07b877ffd270c63dbcdd5201ad9
- https://github.com/manugarg/pacparser/issues/99
- https://github.com/manugarg/pacparser/releases/tag/v1.4.0
- https://vuldb.com/?id.215443
- https://github.com/manugarg/pacparser/commit/853e8f45607cb07b877ffd270c63dbcdd5201ad9
- https://github.com/manugarg/pacparser/issues/99
- https://github.com/manugarg/pacparser/releases/tag/v1.4.0
- https://vuldb.com/?id.215443
Get alerted when CVE-2019-25078 or the next vulnerability affects your stack