What’s Vulnerable › Vulnerabilities
CVE-2019-25094: innologi appointments Extension Appointment cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-04 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability, which was classified as problematic, was found in innologi appointments Extension up to 2.0.5 on TYPO3. This affects an unknown part of the component Appointment Handler. The manipulation of the argument formfield leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.0.6 is able to address this issue. The identifier of the patch is 986d3cb34e5e086c6f04e061f600ffc5837abe7f. It is recommended to upgrade the affected component. The identifier VDB-217353 was assigned to this vulnerability.
Affected products
- innologi Appointment Scheduler: before 2.0.6 — fixed in 2.0.6
How to fix
Upgrade to a fixed version: innologi Appointment Scheduler 2.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/innologi/typo3-appointments/commit/986d3cb34e5e086c6f04e061f600ffc5837abe7f
- https://github.com/innologi/typo3-appointments/releases/tag/2.0.6
- https://vuldb.com/?ctiid.217353
- https://vuldb.com/?id.217353
- https://github.com/innologi/typo3-appointments/commit/986d3cb34e5e086c6f04e061f600ffc5837abe7f
- https://github.com/innologi/typo3-appointments/releases/tag/2.0.6
- https://vuldb.com/?ctiid.217353
- https://vuldb.com/?id.217353
Get alerted when CVE-2019-25094 or the next vulnerability affects your stack