What’s Vulnerable › Vulnerabilities
CVE-2019-25143: GDPR Cookie Compliance <= 4.0.2 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The GDPR Cookie Compliance plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the gdpr_cookie_compliance_reset_settings AJAX action in versions up to, and including, 4.0.2. This makes it possible for authenticated attackers to reset all of the settings.
Affected products
- GDPR Cookie Compliance: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: GDPR Cookie Compliance 4.0.3. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/wordpress-gdpr-cookie-compliance-plugin-fixed-authenticated-settings-deletion-vulnerability/
- https://wpscan.com/vulnerability/5ac51325-a7f5-4d38-9b41-61855206083d
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-gdpr-cookie-compliance-security-bypass-4-0-2/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9116d719-f536-4b8a-9e73-9a8a922f8a35?source=cve
- https://blog.nintechnet.com/wordpress-gdpr-cookie-compliance-plugin-fixed-authenticated-settings-deletion-vulnerability/
- https://wpscan.com/vulnerability/5ac51325-a7f5-4d38-9b41-61855206083d
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-gdpr-cookie-compliance-security-bypass-4-0-2/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9116d719-f536-4b8a-9e73-9a8a922f8a35?source=cve
Get alerted when CVE-2019-25143 or the next vulnerability affects your stack