What’s Vulnerable › Vulnerabilities
CVE-2019-25148: WP HTML Mail < 2.9.1 - HTML Injection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP HTML Mail plugin for WordPress is vulnerable to HTML injection in versions up to, and including, 2.9.0.3 due to insufficient input sanitization. This makes it possible for unauthenticated attackers to inject arbitrary HTML in pages that execute if they can successfully trick a administrator into performing an action such as clicking on a link.
Affected products
- codemiq WP HTML Mail: before 2.9.1 — fixed in 2.9.1
How to fix
Upgrade to a fixed version: codemiq WP HTML Mail 2.9.1. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/multiple-wordpress-plugins-vulnerable-to-html-injection/
- https://plugins.svn.wordpress.org/wp-html-mail/trunk/readme.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b3af900c-4048-4f4f-93e9-c60ca34d015b?source=cve
- https://blog.nintechnet.com/multiple-wordpress-plugins-vulnerable-to-html-injection/
- https://plugins.svn.wordpress.org/wp-html-mail/trunk/readme.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b3af900c-4048-4f4f-93e9-c60ca34d015b?source=cve
Get alerted when CVE-2019-25148 or the next vulnerability affects your stack