What’s Vulnerable › Vulnerabilities
CVE-2019-25151: Funnel Builder <= 1.3.0 - Arbitrary Plugin Activation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-269
Description
The Funnel Builder plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the activate_plugin function in versions up to, and including, 1.3.0. This makes it possible for authenticated attackers to activate any plugin on the vulnerable service.
Affected products
- brainstormforce CartFlows – Funnel Builder & Checkout Plugin for WooCommerce: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: brainstormforce CartFlows – Funnel Builder & Checkout Plugin for WooCommerce 1.3.1. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/privilege-escalation-vulnerability-fixed-in-wordpress-cartflows-plugin/
- https://wpscan.com/vulnerability/b6725319-909f-4d5c-9b34-8b6ea627b223%5D
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-funnel-builder-by-cartflows-create-high-converting-sales-funnels-for-wordpress-privilege-escalation-1-3-0/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f0b95670-0767-4325-88d0-4ae6d7302558?source=cve
- https://blog.nintechnet.com/privilege-escalation-vulnerability-fixed-in-wordpress-cartflows-plugin/
- https://wpscan.com/vulnerability/b6725319-909f-4d5c-9b34-8b6ea627b223%5D
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-funnel-builder-by-cartflows-create-high-converting-sales-funnels-for-wordpress-privilege-escalation-1-3-0/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f0b95670-0767-4325-88d0-4ae6d7302558?source=cve
Get alerted when CVE-2019-25151 or the next vulnerability affects your stack