What’s Vulnerable › Vulnerabilities
CVE-2019-25152: Abandoned Cart Lite for WooCommerce < 5.2.0 and Abandoned Cart Pro for WooCommerce < 7.13.0 - Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Abandoned Cart Lite for WooCommerce and Abandoned Cart Pro for WooCommerce plugins for WordPress are vulnerable to Stored Cross-Site Scripting via multiple parameters in versions up to, and including, 5.1.3 and 7.12.0 respectively, due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in user input that will execute on the admin dashboard.
Affected products
- tychesoftwares Abandoned Cart Lite for WooCommerce: before 5.2.0 — fixed in 5.2.0
- Tyche Softwares Abandoned Cart Pro for WooCommerce: through 7.12.0
How to fix
Upgrade to a fixed version: tychesoftwares Abandoned Cart Lite for WooCommerce 5.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2033212
- https://wpscan.com/vulnerability/9229
- https://www.wordfence.com/blog/2019/03/xss-flaw-in-abandoned-cart-plugin-leads-to-wordpress-site-takeovers/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a9cc5c6d-4396-4ebf-8788-f01dd9e9cfbc?source=cve
- https://plugins.trac.wordpress.org/changeset/2033212
- https://wpscan.com/vulnerability/9229
- https://www.wordfence.com/blog/2019/03/xss-flaw-in-abandoned-cart-plugin-leads-to-wordpress-site-takeovers/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a9cc5c6d-4396-4ebf-8788-f01dd9e9cfbc?source=cve
Get alerted when CVE-2019-25152 or the next vulnerability affects your stack