What’s Vulnerable › Vulnerabilities
CVE-2019-25158: pedroetb tts-api app.js onSpeechDone os command injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-19 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.
Affected products
- pedroetb tts-api: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: pedroetb tts-api 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/pedroetb/tts-api/commit/29d9c25415911ea2f8b6de247cb5c4607d13d434
- https://github.com/pedroetb/tts-api/releases/tag/v2.2.0
- https://vuldb.com/?ctiid.248278
- https://vuldb.com/?id.248278
- https://github.com/pedroetb/tts-api/commit/29d9c25415911ea2f8b6de247cb5c4607d13d434
- https://github.com/pedroetb/tts-api/releases/tag/v2.2.0
- https://vuldb.com/?ctiid.248278
- https://vuldb.com/?id.248278
Get alerted when CVE-2019-25158 or the next vulnerability affects your stack