What’s Vulnerable › Vulnerabilities
CVE-2019-25211
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-29 · updated 2026-06-17
- Weakness: CWE-346
Description
parseWildcardRules in Gin-Gonic CORS middleware before 1.6.0 mishandles a wildcard at the end of an origin string, e.g., https://example.community/* is allowed when the intention is that only https://example.com/* should be allowed, and http://localhost.example.com/* is allowed when the intention is that only http://localhost/* should be allowed.
Affected products
- Gin-Contrib Cors: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Gin-Contrib Cors 1.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/gin-contrib/cors/commit/27b723a473efd80d5a498fa9f5933c80204c850d
- https://github.com/gin-contrib/cors/compare/v1.5.0...v1.6.0
- https://github.com/gin-contrib/cors/pull/106
- https://github.com/gin-contrib/cors/pull/57
- https://github.com/gin-contrib/cors/releases/tag/v1.6.0
- https://github.com/gin-contrib/cors/commit/27b723a473efd80d5a498fa9f5933c80204c850d
- https://github.com/gin-contrib/cors/compare/v1.5.0...v1.6.0
- https://github.com/gin-contrib/cors/pull/106
- https://github.com/gin-contrib/cors/pull/57
- https://github.com/gin-contrib/cors/releases/tag/v1.6.0
- https://lists.debian.org/debian-lts-announce/2025/08/msg00024.html
Get alerted when CVE-2019-25211 or the next vulnerability affects your stack