What’s Vulnerable › Vulnerabilities
CVE-2019-25218: Photo Gallery Slideshow & Masonry Tiled Gallery <= 1.0.3 - Authenticated (Admin+) SQL Injection
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-19 · updated 2026-06-17
- Weakness: CWE-89
Description
The Photo Gallery Slideshow & Masonry Tiled Gallery plugin for WordPress is vulnerable to SQL Injection via the 'id' parameter in all versions up to, and including, 1.0.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- nik00726 Photo Gallery Slideshow & Masonry Tiled Gallery: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: nik00726 Photo Gallery Slideshow & Masonry Tiled Gallery 1.0.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-responsive-photo-gallery/tags/1.0.3/wp-responsive-photo-gallery.php#L1393
- https://plugins.trac.wordpress.org/browser/wp-responsive-photo-gallery/tags/1.0.4/wp-responsive-photo-gallery.php#L1614
- https://wordpress.org/plugins/wp-responsive-photo-gallery/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/05ff1b1e-f7ba-485d-9421-9bb38f6831ef?source=cve
Get alerted when CVE-2019-25218 or the next vulnerability affects your stack