What’s Vulnerable › Vulnerabilities
CVE-2019-25220
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-770
Description
Bitcoin Core before 24.0.1 allows remote attackers to cause a denial of service (daemon crash) via a flood of low-difficulty header chains (aka a "Chain Width Expansion" attack) because a node does not first verify that a presented chain has enough work before committing to store it.
Affected products
- Bitcoin Core: before 24.0.1 — fixed in 24.0.1
How to fix
Upgrade to a fixed version: Bitcoin Core 24.0.1. Check the vendor advisory for mitigations.
References
- https://bitcoincore.org/en/2024/09/18/disclose-headers-oom
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
- https://lists.linuxfoundation.org/pipermail/bitcoin-dev/2019-October/017354.html
Get alerted when CVE-2019-25220 or the next vulnerability affects your stack