What’s Vulnerable › Vulnerabilities
CVE-2019-25225
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-08 · updated 2026-06-17
- Weakness: CWE-79
Description
`sanitize-html` prior to version 2.0.0-beta is vulnerable to Cross-site Scripting (XSS). The `sanitizeHtml()` function in `index.js` does not sanitize content when using the custom `transformTags` option, which is intended to convert attribute values into text. As a result, malicious input can be transformed into executable code.
Affected products
- apostrophecms sanitize-html: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: apostrophecms sanitize-html 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/Checkmarx/Vulnerabilities-Proofs-of-Concept/tree/main/2019/CVE-2019-25225
- https://github.com/apostrophecms/sanitize-html/commit/712cb6895825c8bb6ede71a16b42bade42abcaf3
- https://github.com/apostrophecms/sanitize-html/issues/293
- https://github.com/apostrophecms/sanitize-html/pull/156
Get alerted when CVE-2019-25225 or the next vulnerability affects your stack