What’s Vulnerable › Vulnerabilities
CVE-2019-25295: WP Cost Estimation < 9.660 - Upload Directory Traversal
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-08 · updated 2026-06-17
- Weakness: CWE-22
Description
The WP Cost Estimation plugin for WordPress is vulnerable to Upload Directory Traversal in versions before 9.660 via the uploadFormFiles function. This allows attackers to overwrite any file with a whitelisted type on an affected site.
Affected products
- loopus WP Cost Estimation & Payment Forms Builder: before 9.660 — fixed in 9.660
How to fix
Upgrade to a fixed version: loopus WP Cost Estimation & Payment Forms Builder 9.660. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/wp-cost-estimation-payment-forms-builder/7818230
- https://www.wordfence.com/blog/2019/02/vulnerabilities-patched-in-wp-cost-estimation-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/65a9e877-e870-4e36-985d-c0629abe3f78?source=cve
Get alerted when CVE-2019-25295 or the next vulnerability affects your stack