What’s Vulnerable › Vulnerabilities
CVE-2019-25296: WP Cost Estimation <= 9.642 - Missing Authorization to Arbitrary File Upload/Delete
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-08 · updated 2026-06-17
- Weakness: CWE-434
Description
The WP Cost Estimation plugin for WordPress is vulnerable to arbitrary file uploads and deletion due to missing file type validation in the lfb_upload_form and lfb_removeFile AJAX actions in versions up to, and including, 9.642. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible. Additionally, the attacker can also delete files on the server such as database configuration files, subsequently uploading their own database files.
Affected products
- loopus WP Cost Estimation & Payment Forms Builder: before 9.644 — fixed in 9.644
How to fix
Upgrade to a fixed version: loopus WP Cost Estimation & Payment Forms Builder 9.644. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9219
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-wp-cost-estimation-payment-forms-builder-multiple-vulnerabilities-9-642/
- https://www.wordfence.com/blog/2019/02/vulnerabilities-patched-in-wp-cost-estimation-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ae50aa5d-95e3-4650-9dbf-118b4ba3abda?source=cve
- https://www.zdnet.com/article/another-wordpress-commercial-plugin-gets-exploited-in-the-wild/
- https://www.wordfence.com/blog/2019/02/vulnerabilities-patched-in-wp-cost-estimation-plugin/
Get alerted when CVE-2019-25296 or the next vulnerability affects your stack