What’s Vulnerable › Vulnerabilities
CVE-2019-25297: Poll, Survey & Quiz Maker Plugin by Opinion Stage < 19.6.25 Stored XSS
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Poll, Survey & Quiz Maker Plugin by Opinion Stage Wordpress plugin versions prior to 19.6.25 contain a stored cross-site scripting (XSS) vulnerability via multiple parameters due to insufficient input validation and output escaping. An unauthenticated attacker can inject arbitrary script into content that executes when a victim views an affected page.
Affected products
- Assaf Parag Poll, Survey & Quiz Maker Plugin by Opinion Stage: before 19.6.25 — fixed in 19.6.25
How to fix
Upgrade to a fixed version: Assaf Parag Poll, Survey & Quiz Maker Plugin by Opinion Stage 19.6.25. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2158590/social-polls-by-opinionstage
- https://web.archive.org/web/20191020011448/https://www.pluginvulnerabilities.com/2019/09/16/hackers-may-already-be-targeting-this-persistent-xss-vulnerability-in-poll-survey-form-quiz-maker-by-opinionstage/
- https://wordpress.org/plugins/social-polls-by-opinionstage/
- https://wpscan.com/vulnerability/4ed1edd6-3813-44a3-bee7-f07c1774b679/
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-poll-survey-form-quiz-maker-by-opinionstage-cross-site-scripting-19-6-24/
- https://www.vulncheck.com/advisories/poll-survey-and-quiz-maker-plugin-by-opinion-stage-stored-xss
- https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/social-polls-by-opinionstage/poll-survey-quiz-maker-plugin-by-opinion-stage-19625-unauthenticated-stored-cross-site-scripting
- https://web.archive.org/web/20191020011448/https://www.pluginvulnerabilities.com/2019/09/16/hackers-may-already-be-targeting-this-persistent-xss-vulnerability-in-poll-survey-form-quiz-maker-by-opinionstage/
- https://wpscan.com/vulnerability/4ed1edd6-3813-44a3-bee7-f07c1774b679/
Get alerted when CVE-2019-25297 or the next vulnerability affects your stack