What’s Vulnerable › Vulnerabilities
CVE-2019-25597: NSauditor 3.1.2.0 Denial of Service via Community Field
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-22 · updated 2026-10-07
- Weakness: CWE-787
Description
NSauditor 3.1.2.0 contains a buffer overflow vulnerability in the SNMP Auditor Community field that allows local attackers to crash the application by supplying an excessively long string. Attackers can paste a large payload into the Community field and trigger the Walk function to cause a denial of service condition.
Affected products
- Nsauditor: from 3.1.2.0 before 3.2.7 — fixed in 3.2.7
How to fix
Upgrade to a fixed version: Nsauditor 3.2.7. Check the vendor advisory for mitigations.
References
- http://www.nsauditor.com/downloads/nsauditor_setup.exe
- https://www.exploit-db.com/exploits/46757
- https://www.vulncheck.com/advisories/nsauditor-denial-of-service-via-community-field
Get alerted when CVE-2019-25597 or the next vulnerability affects your stack