What’s Vulnerable › Vulnerabilities
CVE-2019-25777: YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable, which can lead to arbitrary code execution
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-05 · updated 2026-10-06
- Weakness: CWE-914
Description
YAML versions before 1.27_001 for Perl allow a loaded perl/glob document to replace any package variable, which can lead to arbitrary code execution. A perl/glob document names a package and a symbol, and supplies the value assigned to it. Nothing restricts the name, so the target can be @INC or YAML's own load options. A perl/glob document that sets $YAML::LoadCode or $YAML::UseCode turns on code loading, which is off by default, for every later Load() in the process. A perl/code document is then passed to a string eval, so an attacker who supplies two documents to separate Load() calls in one process can execute arbitrary Perl code.
Affected products
- YAML: before 1.27_001 — fixed in 1.27_001
How to fix
Upgrade to a fixed version: YAML 1.27_001. Check the vendor advisory for mitigations.
References
- https://github.com/ingydotnet/yaml-pm/commit/bace96b5e6661d521c7c515c94a09e081c911fce.patch
- https://github.com/ingydotnet/yaml-pm/issues/212
- https://metacpan.org/release/TINITA/YAML-1.28/changes
- http://www.openwall.com/lists/oss-security/2026/10/05/7
Get alerted when CVE-2019-25777 or the next vulnerability affects your stack