What’s Vulnerable › Vulnerabilities
CVE-2019-2602
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-23 · updated 2026-06-17
- Weakness: CWE-400
Description
Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Libraries). Supported versions that are affected are Java SE: 7u211, 8u202, 11.0.2 and 12; Java SE Embedded: 8u201. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of Java SE, Java SE Embedded. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 7.5 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H).
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10, 19.10
- Debian Linux: 8.0, 9.0
- HP Xp7 Command View: before 8.6.5-00 — fixed in 8.6.5-00
- McAfee,LLC McAfee ePolicy Orchestrator (ePO): 5.9.0, 5.9.1, 5.10.0
- openSUSE Leap: 15.0, 42.3
- Oracle Java SE: 1.7.0-update211, 1.8.0-update201, 1.8.0-update202, 11.0.2, 12
- Oracle Java SE: 1.7.0-update211, 1.8.0-update201, 1.8.0-update202, 11.0.2, 12
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 8.1, 8.2, 8.4, 8.6
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 8.2, 8.4, 8.6
- RedHat Enterprise Linux Server Tus: 8.2, 8.4, 8.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- Red Hat OpenShift Container Platform 4.18: 3.11
- Red Hat Satellite 6: 5.8
How to fix
Upgrade to a fixed version: HP Xp7 Command View 8.6.5-00. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00013.html
- http://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
- https://access.redhat.com/errata/RHBA-2019:0959
- https://access.redhat.com/errata/RHSA-2019:1146
- https://access.redhat.com/errata/RHSA-2019:1163
- https://access.redhat.com/errata/RHSA-2019:1164
- https://access.redhat.com/errata/RHSA-2019:1165
- https://access.redhat.com/errata/RHSA-2019:1166
- https://access.redhat.com/errata/RHSA-2019:1238
Get alerted when CVE-2019-2602 or the next vulnerability affects your stack