What’s Vulnerable › Vulnerabilities
CVE-2019-2769
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-23 · updated 2026-06-17
Description
Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Utilities). Supported versions that are affected are Java SE: 7u221, 8u212, 11.0.3 and 12.0.1; Java SE Embedded: 8u211. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS 3.0 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04
- Debian Linux: 8.0
- HP Xp7 Command View: before 8.7.0-00 — fixed in 8.7.0-00
- McAfee,LLC McAfee ePolicy Orchestrator (ePO): 5.9.0, 5.9.1, 5.10.0, 5.10.0-update_1, 5.10.0-update_2, 5.10.0-update_3 (+1)
- openSUSE Leap: 15.0, 15.1
- Oracle Java SE: 1.7.0-update221, 1.8.0-update211, 1.8.0-update212, 11.0.3, 12.0.1
- Oracle Java SE: 1.7.0-update221, 1.8.0-update211, 1.8.0-update212, 11.0.3, 12.0.1
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 8.6
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- Red Hat Satellite 6: 5.8
How to fix
Upgrade to a fixed version: HP Xp7 Command View 8.7.0-00. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00038.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00044.html
- http://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
- https://access.redhat.com/errata/RHSA-2019:2494
- https://access.redhat.com/errata/RHSA-2019:2495
- https://access.redhat.com/errata/RHSA-2019:2585
- https://access.redhat.com/errata/RHSA-2019:2590
- https://access.redhat.com/errata/RHSA-2019:2592
- https://access.redhat.com/errata/RHSA-2019:2737
- https://kc.mcafee.com/corporate/index?page=content&id=SB10300
- https://lists.debian.org/debian-lts-announce/2019/08/msg00020.html
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03977en_us
Get alerted when CVE-2019-2769 or the next vulnerability affects your stack