What’s Vulnerable › Vulnerabilities
CVE-2019-2999
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-16 · updated 2026-06-17
Description
Vulnerability in the Java SE product of Oracle Java SE (component: Javadoc). Supported versions that are affected are Java SE: 7u231, 8u221, 11.0.4 and 13. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE accessible data as well as unauthorized read access to a subset of Java SE accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.0 Base Score 4.7 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N).
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04, 19.10
- Debian Linux: 8.0, 9.0, 10.0
- E-Series SANtricity OS Controller Software 11.x: from 11.0.0 through 11.50.2
- NetApp E-Series Santricity Storage Manager: all versions
- NetApp E-Series Santricity Unified Manager: all versions
- NetApp E-Series Santricity Web Services Proxy: all versions
- NetApp OnCommand Workflow Automation: all versions
- SnapManager for Oracle: all versions
- openSUSE Leap: 15.0, 15.1
- Oracle Java SE: 1.7.0-update231, 1.8.0-update221, 11.0.4, 13.0.0
- Oracle Java SE: 1.7.0-update231, 1.8.0-update221, 11.0.4, 13.0.0
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 7.7, 8.1, 8.6
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.7
- RedHat Enterprise Linux Server Tus: 7.7
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- Red Hat Satellite 6: 5.8
References
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00066.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00031.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
- https://access.redhat.com/errata/RHSA-2019:3134
- https://access.redhat.com/errata/RHSA-2019:3135
- https://access.redhat.com/errata/RHSA-2019:3136
- https://access.redhat.com/errata/RHSA-2019:3157
- https://access.redhat.com/errata/RHSA-2019:3158
- https://access.redhat.com/errata/RHSA-2019:4109
- https://access.redhat.com/errata/RHSA-2019:4110
- https://access.redhat.com/errata/RHSA-2019:4113
Get alerted when CVE-2019-2999 or the next vulnerability affects your stack