What’s Vulnerable › Vulnerabilities
CVE-2019-3395
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-25 · updated 2026-06-17
- Weakness: CWE-918
Description
The WebDAV endpoint in Atlassian Confluence Server and Data Center before version 6.6.7 (the fixed version for 6.6.x), from version 6.7.0 before 6.8.5 (the fixed version for 6.8.x), and from version 6.9.0 before 6.9.3 (the fixed version for 6.9.x) allows remote attackers to send arbitrary HTTP and WebDAV requests from a Confluence Server or Data Center instance via Server-Side Request Forgery.
Affected products
- Atlassian Confluence: before 6.6.12; from 6.7.0 before 6.12.3 — fixed in 6.12.3, 6.6.12
- Atlassian Confluence Data Center: from 6.13.0 before 6.13.3; from 6.14.0 before 6.14.2 — fixed in 6.13.3, 6.14.2
How to fix
Upgrade to a fixed version: Atlassian Confluence 6.12.3, 6.6.12; Atlassian Confluence Data Center 6.13.3, 6.14.2. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-57971
- https://jira.atlassian.com/browse/CONFSERVER-57971
Get alerted when CVE-2019-3395 or the next vulnerability affects your stack