What’s Vulnerable › Vulnerabilities

CVE-2019-3396: Atlassian Confluence Server and Data Center Server-Side Template Injection Vulnerability

Description

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

Affected products

How to fix

Upgrade to a fixed version: Atlassian Confluence Data Center 6.12.3, 6.13.3, 6.14.2, 6.6.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-3396 or the next vulnerability affects your stack