What’s Vulnerable › Vulnerabilities
CVE-2019-3397
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-03 · updated 2026-06-17
- Weakness: CWE-22
Description
Atlassian Bitbucket Data Center licensed instances starting with version 5.13.0 before 5.13.6 (the fixed version for 5.13.x), from 5.14.0 before 5.14.4 (fixed version for 5.14.x), from 5.15.0 before 5.15.3 (fixed version for 5.15.x), from 5.16.0 before 5.16.3 (fixed version for 5.16.x), from 6.0.0 before 6.0.3 (fixed version for 6.0.x), and from 6.1.0 before 6.1.2 (the fixed version for 6.1.x) allow remote attackers who have admin permissions to achieve remote code execution on a Bitbucket server instance via path traversal through the Data Center migration tool.
Affected products
- Atlassian Bitbucket Server: from 5.13.0 before 5.13.6; from 5.14.0 before 5.14.4; from 5.15.0 before 5.15.3; from 5.16.0 before 5.16.3; from 6.0.0 before 6.0.3; from 6.1.0 before 6.1.2 — fixed in 5.13.6, 5.14.4, 5.15.3, 5.16.3, 6.0.3, 6.1.2
How to fix
Upgrade to a fixed version: Atlassian Bitbucket Server 5.13.6, 5.14.4, 5.15.3, 5.16.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3397 or the next vulnerability affects your stack