What’s Vulnerable › Vulnerabilities
CVE-2019-3462
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-28 · updated 2026-06-17
Description
Incorrect sanitation of the 302 redirect field in HTTP transport method of apt versions 1.4.8 and earlier can lead to content injection by a MITM attacker, potentially leading to remote code execution on the target machine.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 18.10
- Debian Advanced Package Tool: before 1.2.30; from 1.3 through 1.4.8 — fixed in 1.2.30
- Debian Linux: 8.0, 9.0
- NetApp Active Iq: all versions
- NetApp Element Software: all versions
How to fix
Upgrade to a fixed version: Debian Advanced Package Tool 1.2.30. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106690
- https://lists.apache.org/thread.html/8338a0f605bdbb3a6098bb76f666a95fc2b2f53f37fa1ecc89f1146f%40%3Cdevnull.infra.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2019/01/msg00013.html
- https://lists.debian.org/debian-lts-announce/2019/01/msg00014.html
- https://security.netapp.com/advisory/ntap-20190125-0002/
- https://usn.ubuntu.com/3863-1/
- https://usn.ubuntu.com/3863-2/
- https://www.debian.org/security/2019/dsa-4371
- http://www.securityfocus.com/bid/106690
- https://lists.apache.org/thread.html/8338a0f605bdbb3a6098bb76f666a95fc2b2f53f37fa1ecc89f1146f%40%3Cdevnull.infra.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2019/01/msg00013.html
- https://lists.debian.org/debian-lts-announce/2019/01/msg00014.html
Get alerted when CVE-2019-3462 or the next vulnerability affects your stack