What’s Vulnerable › Vulnerabilities
CVE-2019-3563
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-29 · updated 2026-06-17
- Weakness: CWE-126
Description
Wangle's LineBasedFrameDecoder contains logic for identifying newlines which incorrectly advances a buffer, leading to a potential underflow. This affects versions of Wangle prior to v2019.04.22.00
Affected products
- Facebook Wangle: before 2019.04.22.00 — fixed in 2019.04.22.00
How to fix
Upgrade to a fixed version: Facebook Wangle 2019.04.22.00. Check the vendor advisory for mitigations.
References
- https://github.com/facebook/wangle/commit/5b3bceca875e4ea4ed9d14c20b20ce46c92c13c6
- https://github.com/facebook/wangle/commit/5b3bceca875e4ea4ed9d14c20b20ce46c92c13c6
Get alerted when CVE-2019-3563 or the next vulnerability affects your stack