What’s Vulnerable › Vulnerabilities

CVE-2019-3568: WhatsApp VOIP Stack Buffer Overflow Vulnerability

Description

A buffer overflow vulnerability in WhatsApp VOIP stack allowed remote code execution via specially crafted series of RTCP packets sent to a target phone number. The issue affects WhatsApp for Android prior to v2.19.134, WhatsApp Business for Android prior to v2.19.44, WhatsApp for iOS prior to v2.19.51, WhatsApp Business for iOS prior to v2.19.51, WhatsApp for Windows Phone prior to v2.18.348, and WhatsApp for Tizen prior to v2.18.15.

Affected products

How to fix

Upgrade to a fixed version: Facebook WhatsApp for Android 2.18.15, 2.18.348, 2.19.134, 2.19.51; Whatsapp Business 2.19.44, 2.19.51. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-3568 or the next vulnerability affects your stack