What’s Vulnerable › Vulnerabilities
CVE-2019-3581: McAfee Web Gateway denial of service attack due to Improper Input Validation
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper input validation in the proxy component of McAfee Web Gateway 7.8.2.0 and later allows remote attackers to cause a denial of service via a crafted HTTP request parameter.
Affected products
- McAfee Web Gateway: from 7.8.2.0 before 7.8.2.5; from 8.0.0.0 before 8.0.2.0 — fixed in 7.8.2.5, 8.0.2.0
How to fix
Upgrade to a fixed version: McAfee Web Gateway 7.8.2.5, 8.0.2.0. Check the vendor advisory for mitigations.
References
- https://kc.mcafee.com/corporate/index?page=content&id=SB10264
- https://kc.mcafee.com/corporate/index?page=content&id=SB10264
Get alerted when CVE-2019-3581 or the next vulnerability affects your stack