What’s Vulnerable › Vulnerabilities
CVE-2019-3602: Cross site scripting vulnerability in McAfee NSM impacting authenticated users
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability in McAfee Network Security Manager (NSM) Prior to 9.1 Update 5 allows an authenticated administrator to embed an XSS in the administrator interface via a specially crafted custom rule containing HTML.
Affected products
- McAfee Network Security Management (NSM): before 9.1; 9.1, 9.1-update_1, 9.1-update_2, 9.1-update_3, 9.1-update_4 — fixed in 9.1
How to fix
Upgrade to a fixed version: McAfee Network Security Management (NSM) 9.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108400
- https://kc.mcafee.com/corporate/index?page=content&id=SB10281
- http://www.securityfocus.com/bid/108400
- https://kc.mcafee.com/corporate/index?page=content&id=SB10281
Get alerted when CVE-2019-3602 or the next vulnerability affects your stack