What’s Vulnerable › Vulnerabilities
CVE-2019-3693: Local privilege escalation from user wwwrun to root in the packaging of mailman
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-24 · updated 2026-06-17
- Weakness: CWE-59
Description
A symlink following vulnerability in the packaging of mailman in SUSE Linux Enterprise Server 11, SUSE Linux Enterprise Server 12; openSUSE Leap 15.1 allowed local attackers to escalate their privileges from user wwwrun to root. Additionally arbitrary files could be changed to group mailman. This issue affects: SUSE Linux Enterprise Server 11 mailman versions prior to 2.1.15-9.6.15.1. SUSE Linux Enterprise Server 12 mailman versions prior to 2.1.17-3.11.1. openSUSE Leap 15.1 mailman version 2.1.29-lp151.2.14 and prior versions.
Affected products
- openSUSE Backports Sle: 15.0-sp1
- SUSE Mailman: before 2.1.15-9.6.15.1; before 2.1.17-3.11.1; through 2.1.29-lp151.2.14 — fixed in 2.1.15-9.6.15.1, 2.1.17-3.11.1
How to fix
Upgrade to a fixed version: SUSE Mailman 2.1.15-9.6.15.1, 2.1.17-3.11.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00000.html
- https://bugzilla.suse.com/show_bug.cgi?id=1154328
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00000.html
- https://bugzilla.suse.com/show_bug.cgi?id=1154328
Get alerted when CVE-2019-3693 or the next vulnerability affects your stack