What’s Vulnerable › Vulnerabilities
CVE-2019-3700: yast: Fallback to DES without configuration in /etc/login.def
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-24 · updated 2026-06-17
- Weakness: CWE-327
Description
yast2-security didn't use secure defaults to protect passwords. This became a problem on 2019-10-07 when configuration files that set secure settings were moved to a different location. As of the 20191022 snapshot the insecure default settings were used until yast2-security switched to stronger defaults in 4.2.6 and used the new configuration file locations. Password created during this time used DES password encryption and are not properly protected against attackers that are able to access the password hashes.
Affected products
- SUSE Yast2-Security: before 4.2.6 — fixed in 4.2.6
How to fix
Upgrade to a fixed version: SUSE Yast2-Security 4.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3700 or the next vulnerability affects your stack