What’s Vulnerable › Vulnerabilities

CVE-2019-3705: Buffer Overflow Vulnerability

Description

Dell EMC iDRAC6 versions prior to 2.92, iDRAC7/iDRAC8 versions prior to 2.61.60.60, and iDRAC9 versions prior to 3.20.21.20, 3.21.24.22, 3.21.26.22 and 3.23.23.23 contain a stack-based buffer overflow vulnerability. An unauthenticated remote attacker may potentially exploit this vulnerability to crash the webserver or execute arbitrary code on the system with privileges of the webserver by sending specially crafted input data to the affected system.

Affected products

How to fix

Upgrade to a fixed version: Dell Idrac6 Firmware 2.92; Dell Idrac7 Firmware 2.61.60.60; Dell Idrac8 Firmware 2.61.60.60; Dell EMC iDRAC 3.20.21.20. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-3705 or the next vulnerability affects your stack