What’s Vulnerable › Vulnerabilities
CVE-2019-3712: DSA-2019-039: Dell Wyse Device Agent Buffer Overflow Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-07 · updated 2026-06-17
- Weakness: CWE-119
Description
Dell WES Wyse Device Agent versions prior to 14.1.2.9 and Dell Wyse ThinLinux HAgent versions prior to 5.4.55 00.10 contain a buffer overflow vulnerability. An unauthenticated attacker may potentially exploit this vulnerability to execute arbitrary code on the system with privileges of the FTP client by sending specially crafted input data to the affected system. The FTP code that contained the vulnerability has been removed.
Affected products
- Dell Windows Embedded Standard Wyse Device Agent: before 14.1.2.9 — fixed in 14.1.2.9
- Dell Wyse ThinLinux HAgent: before 5.4.55_00.10 — fixed in 5.4.55_00.10
How to fix
Upgrade to a fixed version: Dell Windows Embedded Standard Wyse Device Agent 14.1.2.9; Dell Wyse ThinLinux HAgent 5.4.55_00.10. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107376
- https://www.dell.com/support/article/us/en/19/sln316391
- http://www.securityfocus.com/bid/107376
- https://www.dell.com/support/article/us/en/19/sln316391
Get alerted when CVE-2019-3712 or the next vulnerability affects your stack