What’s Vulnerable › Vulnerabilities
CVE-2019-3717
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-05 · updated 2026-06-17
Description
Select Dell Client Commercial and Consumer platforms contain an Improper Access Vulnerability. An unauthenticated attacker with physical access to the system could potentially bypass intended Secure Boot restrictions to run unsigned and untrusted code on expansion cards installed in the system during platform boot. Refer to https://www.dell.com/support/article/us/en/04/sln317683/dsa-2019-043-dell-client-improper-access-control-vulnerability?lang=en for versions affected by this vulnerability.
Affected products
- Dell Chengming 3967 Firmware: before 1.5.0 — fixed in 1.5.0
- Dell Chengming 3977 Firmware: before 1.6.0 — fixed in 1.6.0
- Dell Chengming 3980 Firmware: before 1.5.21 — fixed in 1.5.21
- Dell Embedded Box Pc 5000 Firmware: before 1.5.6 — fixed in 1.5.6
- Dell G3 3579 Firmware: before 1.9.0 — fixed in 1.9.0
- Dell G3 3779 Firmware: before 1.9.0 — fixed in 1.9.0
- Dell G5 5587 Firmware: before 1.10.0 — fixed in 1.10.0
- Dell G5 5590 Firmware: before 1.3.1 — fixed in 1.3.1
- Dell G7 7588 Firmware: before 1.10.0 — fixed in 1.10.0
- Dell G7 7590 Firmware: before 1.3.1 — fixed in 1.3.1
- Dell G7 7790 Firmware: before 1.3.1 — fixed in 1.3.1
- Dell Inspiron 3153 Firmware: before 1.22.0 — fixed in 1.22.0
- Dell Inspiron 3158 Firmware: before 1.22.0 — fixed in 1.22.0
- Dell Inspiron 3268 Firmware: before 1.11.1 — fixed in 1.11.1
- Dell Inspiron 3458 Firmware: before a18 — fixed in a18
- Dell Inspiron 3459 Firmware: before 1.9.0 — fixed in 1.9.0
- Dell Inspiron 3467 Firmware: before 2.9.0 — fixed in 2.9.0
- Dell Inspiron 3468 Firmware: before 1.12.0 — fixed in 1.12.0
- Dell Inspiron 3470 Firmware: before 1.5.21 — fixed in 1.5.21
- Dell Inspiron 3476 Firmware: before 1.7.0 — fixed in 1.7.0
- Dell Inspiron 3480 Firmware: before 1.4.1 — fixed in 1.4.1
- Dell Inspiron 3481 Firmware: before 1.2.0 — fixed in 1.2.0
- Dell Inspiron 3558 Firmware: before a18 — fixed in a18
- Dell Inspiron 3559 Firmware: before 1.9.0 — fixed in 1.9.0
- Dell Inspiron 3567 Firmware: before 2.9.0 — fixed in 2.9.0
- Dell Inspiron 3568 Firmware: before 1.12.0 — fixed in 1.12.0
- Dell Inspiron 3576 Firmware: before 1.7.0 — fixed in 1.7.0
- Dell Inspiron 3580 Firmware: before 1.4.1 — fixed in 1.4.1
- Dell Inspiron 3581 Firmware: before 1.2.0 — fixed in 1.2.0
- Dell Inspiron 3583 Firmware: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Dell Chengming 3967 Firmware 1.5.0; Dell Chengming 3977 Firmware 1.6.0; Dell Chengming 3980 Firmware 1.5.21; Dell Embedded Box Pc 5000 Firmware 1.5.6; Dell G3 3579 Firmware 1.9.0; Dell G3 3779 Firmware 1.9.0; Dell G5 5587 Firmware 1.10.0; Dell G5 5590 Firmware 1.3.1; Dell G7 7588 Firmware 1.10.0; Dell G7 7590 Firmware 1.3.1; Dell G7 7790 Firmware 1.3.1; Dell Inspiron 3153 Firmware 1.22.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/article/us/en/04/sln317683/dsa-2019-043-dell-client-improper-access-control-vulnerability?lang=en
- https://www.dell.com/support/article/us/en/04/sln317683/dsa-2019-043-dell-client-improper-access-control-vulnerability?lang=en
Get alerted when CVE-2019-3717 or the next vulnerability affects your stack