What’s Vulnerable › Vulnerabilities
CVE-2019-3719
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-18 · updated 2026-06-17
Description
Dell SupportAssist Client versions prior to 3.2.0.90 contain a remote code execution vulnerability. An unauthenticated attacker, sharing the network access layer with the vulnerable system, can compromise the vulnerable system by tricking a victim user into downloading and executing arbitrary executables via SupportAssist client from attacker hosted sites.
Affected products
- Dell SupportAssist Client: before 3.2.0.90 — fixed in 3.2.0.90
How to fix
Upgrade to a fixed version: Dell SupportAssist Client 3.2.0.90. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/article/us/en/19/sln316857/dsa-2019-051-dell-supportassist-client-multiple-vulnerabilities?lang=en
- https://www.dell.com/support/article/us/en/19/sln316857/dsa-2019-051-dell-supportassist-client-multiple-vulnerabilities?lang=en
Get alerted when CVE-2019-3719 or the next vulnerability affects your stack