What’s Vulnerable › Vulnerabilities
CVE-2019-3721: Improper Range Header Processing Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-25 · updated 2026-06-17
- Weakness: CWE-770
Description
Dell EMC Open Manage System Administrator (OMSA) versions prior to 9.3.0 contain an Improper Range Header Processing Vulnerability. A remote unauthenticated attacker may send crafted requests with overlapping ranges to cause the application to compress each of the requested bytes, resulting in a crash due to excessive memory consumption and preventing users from accessing the system.
Affected products
- Dell EMC Open Manage System Administrator: before 9.3.0 — fixed in 9.3.0
How to fix
Upgrade to a fixed version: Dell EMC Open Manage System Administrator 9.3.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108092
- https://www.dell.com/support/article/us/en/04/sln316915/dsa-2019-060-dell-emc-open-manage-system-administrator-multiple-vulnerabilities?lang=en
- http://www.securityfocus.com/bid/108092
- https://www.dell.com/support/article/us/en/04/sln316915/dsa-2019-060-dell-emc-open-manage-system-administrator-multiple-vulnerabilities?lang=en
Get alerted when CVE-2019-3721 or the next vulnerability affects your stack