What’s Vulnerable › Vulnerabilities
CVE-2019-3726
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-24 · updated 2026-06-17
- Weakness: CWE-427
Description
An Uncontrolled Search Path Vulnerability is applicable to the following: Dell Update Package (DUP) Framework file versions prior to 19.1.0.413, and Framework file versions prior to 103.4.6.69 used in Dell EMC Servers. Dell Update Package (DUP) Framework file versions prior to 3.8.3.67 used in Dell Client Platforms. The vulnerability is limited to the DUP framework during the time window when a DUP is being executed by an administrator. During this time window, a locally authenticated low privilege malicious user potentially could exploit this vulnerability by tricking an administrator into running a trusted binary, causing it to load a malicious DLL and allowing the attacker to execute arbitrary code on the victim system. The vulnerability does not affect the actual binary payload that the DUP delivers.
Affected products
- Dell Update Package Framework: before 3.8.3.67; before 103.4.6.69; before 19.1.0.413 — fixed in 103.4.6.69, 19.1.0.413, 3.8.3.67
How to fix
Upgrade to a fixed version: Dell Update Package Framework 103.4.6.69, 19.1.0.413, 3.8.3.67. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3726 or the next vulnerability affects your stack