What’s Vulnerable › Vulnerabilities
CVE-2019-3728
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-30 · updated 2026-06-17
- Weakness: CWE-125
Description
RSA BSAFE Crypto-C Micro Edition versions from 4.0.0.0 before 4.0.5.4 and from 4.1.0 before 4.1.4, RSA BSAFE Micro Edition Suite versions from 4.0.0 before 4.0.13 and from 4.1.0 before 4.4 and RSA Crypto-C versions from 6.0.0 through 6.4.* are vulnerable to an out-of-bounds read vulnerability when processing DSA signature. A malicious remote user could potentially exploit this vulnerability to cause a crash in the library of the affected system.
Affected products
- Dell Bsafe Crypto-C: from 6.0.0 through 6.4
- Dell Bsafe Crypto-C-Micro-Edition: from 4.0.0 before 4.0.5.4; from 4.1.0 before 4.1.4 — fixed in 4.0.5.4, 4.1.4
- Dell RSA BSAFE MES: from 4.0.0 before 4.0.13; from 4.1.0 before 4.4.0 — fixed in 4.0.13, 4.4.0
How to fix
Upgrade to a fixed version: Dell Bsafe Crypto-C-Micro-Edition 4.0.5.4, 4.1.4; Dell RSA BSAFE MES 4.0.13, 4.4.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/000194054
- https://www.dell.com/support/kbdoc/000194054
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2025-2140
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2025-2141
Get alerted when CVE-2019-3728 or the next vulnerability affects your stack