What’s Vulnerable › Vulnerabilities

CVE-2019-3729

Description

RSA BSAFE Micro Edition Suite versions prior to 4.4 (in 4.0.x, 4.1.x, 4.2.x and 4.3.x) are vulnerable to a Heap-based Buffer Overflow vulnerability when parsing ECDSA signature. A malicious user with adjacent network access could potentially exploit this vulnerability to cause a crash in the library of the affected system.

Affected products

How to fix

Upgrade to a fixed version: Dell RSA BSAFE MES 4.0.13, 4.4.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-3729 or the next vulnerability affects your stack