What’s Vulnerable › Vulnerabilities
CVE-2019-3742
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-09 · updated 2026-06-17
Description
Dell/Alienware Digital Delivery versions prior to 3.5.2013 contain a privilege escalation vulnerability. A local non-privileged malicious user could exploit a named pipe that performs binary deserialization via a process hollowing technique to inject malicous code to run an executable with elevated privileges.
Affected products
- Dell Digital Delivery: before 3.5.2013; from 4.0.15.0 before 4.0.41 — fixed in 3.5.2013, 4.0.41
How to fix
Upgrade to a fixed version: Dell Digital Delivery 3.5.2013, 4.0.41. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3742 or the next vulnerability affects your stack