What’s Vulnerable › Vulnerabilities
CVE-2019-3745
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-07 · updated 2026-06-17
- Weakness: CWE-427
Description
The vulnerability is limited to the installers of Dell Encryption Enterprise versions prior to 10.4.0 and Dell Endpoint Security Suite Enterprise versions prior to 2.4.0. This issue is exploitable only during the installation of the product by an administrator. A local authenticated low privileged user potentially could exploit this vulnerability by staging a malicious DLL in the search path of the installer prior to its execution by a local administrator. This would cause loading of the malicious DLL, which would allow the attacker to execute arbitrary code in the context of an administrator.
Affected products
- Dell Encryption: before 10.4.0 — fixed in 10.4.0
- Dell Endpoint Security Suite Enterprise: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Dell Encryption 10.4.0; Dell Endpoint Security Suite Enterprise 2.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3745 or the next vulnerability affects your stack