What’s Vulnerable › Vulnerabilities
CVE-2019-3754
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell EMC Unity Operating Environment versions prior to 5.0.0.0.5.116, Dell EMC UnityVSA versions prior to 5.0.0.0.5.116 and Dell EMC VNXe3200 versions prior to 3.1.10.9946299 contain a reflected cross-site scripting vulnerability on the cas/logout page. A remote unauthenticated attacker could potentially exploit this vulnerability by tricking a victim application user to supply malicious HTML or Java Script code to Unisphere, which is then reflected back to the victim and executed by the web browser.
Affected products
- Dell Emc Unity Operating Environment: before 5.0.0.0.5.116 — fixed in 5.0.0.0.5.116
- Dell Emc Unityvsa Operating Environment: before 5.0.0.0.5.116 — fixed in 5.0.0.0.5.116
- Dell Emc Vnxe3200 Firmware: before 3.1.10.9946299 — fixed in 3.1.10.9946299
How to fix
Upgrade to a fixed version: Dell Emc Unity Operating Environment 5.0.0.0.5.116; Dell Emc Unityvsa Operating Environment 5.0.0.0.5.116; Dell Emc Vnxe3200 Firmware 3.1.10.9946299. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/security/en-us/details/536796/DSA-2019-125-Dell-EMC-Unity-and-VNXe3200-Family-Reflected-Cross-Site-Scripting-Vulnerability
- https://www.dell.com/support/security/en-us/details/536796/DSA-2019-125-Dell-EMC-Unity-and-VNXe3200-Family-Reflected-Cross-Site-Scripting-Vulnerability
Get alerted when CVE-2019-3754 or the next vulnerability affects your stack