What’s Vulnerable › Vulnerabilities
CVE-2019-3770
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell Wyse Management Suite versions prior to 1.4.1 contain a stored cross-site scripting vulnerability when unregistering a device. A remote authenticated malicious user with low privileges could exploit this vulnerability to store malicious HTML or JavaScript code. When victim users access the submitted data through their browsers, the malicious code gets executed by the web browser in the context of the vulnerable application.
Affected products
- Dell Wyse Management Suite: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Dell Wyse Management Suite 1.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3770 or the next vulnerability affects your stack