What’s Vulnerable › Vulnerabilities
CVE-2019-3779: Cloud Foundry Container Runtime allows a user to bypass security policy when talking to ETCD
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-08 · updated 2026-06-17
- Weakness: CWE-284
Description
Cloud Foundry Container Runtime, versions prior to 0.29.0, deploys Kubernetes clusters utilize the same CA (Certificate Authority) to sign and trust certs for ETCD as used by the Kubernetes API. This could allow a user authenticated with a cluster to request a signed certificate leveraging the Kubernetes CSR capability to obtain a credential that could escalate privilege access to ETCD.
Affected products
- Cloud Foundry Container Runtime (CFCR): before 0.29.0 — fixed in 0.29.0
How to fix
Upgrade to a fixed version: Cloud Foundry Container Runtime (CFCR) 0.29.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3779 or the next vulnerability affects your stack